-
图解车载以太网 TCP 协议
“ 无论在互联网领域还是汽车以太网领域,TCP/IP 协议族中传输层的传输控制协议(Transmission Control Protocol,TCP)都有举足轻重的作用和大量的应用场景。TCP 是一种面向连接的、可靠的、基于字节流的通信协议,最初由 IETF RFC 793 定义,后续在 RFC 1122、RFC 2581 等文档中都进行了修订和补充。... 秋名山车神
- 0
- 0
- 236
-
UDS统一诊断服务【五】诊断仪在线0X3E服务
诊断仪在线服务比较简单,其功能就是告诉服务端,诊断仪还是处于连着的状态,不要切换状态。比如,当你想从默认会话模式切换到扩展会话模式,并保持在扩展会话模式时,此时可以周期性发送3E服务。因为,如果不在默认会话模式,超过S3时间,ECU就会自动切换到默认会话,3E服务可保持在你其他模式下。... 爱知ev
- 0
- 3
- 665
-
车载以太网 TSN 入门篇
开始介绍之前,我们先简单了解一下背景。提到TSN,就绕不开IEEE 802.1 Working Group,此工作组负责 IEEE 802.1 一系列标准的制定,其内容包含 IEEE 802 局域网/城域网架构、局域网/城域网和其他广域网络下的互连问题、网络的整体网络管理以及 MAC 和 LLC 层之上的上层协议。这里的上层协议,指的就是TSN的一系列机制,现在常见的车载以太网均使用Etherne…... 秋名山车神
- 0
- 1
- 905
-
一文搞懂UDS的各种时间参数
在一开始做诊断的时候,看到这么多时间参数,真是头大,很多还长得很像,N_As,N_Bs, N_Cs等,这些到底代表啥含义呢?刚开始确实很头疼,我也是直接忽略,做其他任务开发,等基本功能都开发完了,后面发现升级的时候,出问题了,定位到和这些时间参数有问题,这才去研究这些参数的含义。接下来介绍一下这些参数。... 爱知ev
- 2
- 20
- 9.3k
-
UDS统一诊断服务【三】安全访问0X27服务
SecurityAccess 安全访问,27服务,用来保护某些诊断服务的,提供一种保护机制。例如对于重要数据的上传或者下载过程不做任何限制,可能会对整车的安全造成极大的威胁,尤其是针对底盘域的控制器更是要在这方面做好全方位的安全防保护措施。... 爱知ev
- 0
- 3
- 1.5k
-
UDS统一诊断服务【十二】读取DTC信息0X19服务
19服务(ReadDTCInformation):用于读取ECU的故障信息,该服务允许客户端从任何服务器或车辆内的一组服务器读取服务器驻留的诊断故障代码(DTC)信息的状态。除非特定子功能另有要求,否则服务器应返回所有DTC信息。... 爱知ev
- 0
- 5
- 5.5k
-
UDS统一诊断服务【八】通过DID读取数据0X22服务
DID:Data Identifier 数据标识符,简单理解就是个编号,用来标识要读取的是什么内容,比如,你要读取软件版本号,硬件版本号,那发送的DID就不一样了。... 爱知ev
- 2
- 1
- 1.6k
-
大端 vs 小端 — 车内通 信
上篇文章我们介绍了大端和小端的概念,那么车内通信的时候具体是使用大端还是小端呢?CAN总线中的Intel和Motorola格式和大小端又有什么关系?... 秋名山车神
- 1
- 2
- 1k
-
如何排查CAN FD 总线错误帧?
最近样车调试遇到了一个CANFD总线错误帧的问题,排查了很长时间,且其故障原因为首次遇到,特在此记录并分享给大家,希望能够对后续遇到同样问题的同行有所帮助。... 电车小子
- 0
- 5
- 1k
-
SOME/IP 详解(2) —— 报文格式
随着车载以太网技术的快速发展,SOME/IP得到了更多在车内网络应用的机会, 同时 作为 SOA架构的重要支撑, 也越来越受到人们的关注。 但还是有很多人并不是真正的了解SOME/IP,王师傅打算通过《SOME/IP详解》系列的几篇文章,详细的介绍下SOME/IP的背景、定义、工作机制和应用场景,以及如何通过工具去进行SOME/IP的仿真和验证。... 秋名山车神
- 0
- 1
- 872
-
UDS统一诊断服务【一】诊断会话控制0X10服务
诊断会话控制服务 DiagnosticSessionControl,SID是0X10,主要功能是控制服务端的会话模式切换。一般默认上电后是在默认会话模式下,当某一个服务端正在运行时,只会出现一个会话模式,不会同时存在两个会话模式。... 爱知ev
- 1
- 3
- 1.1k
-
UDS统一诊断服务【十一】例程控制0X31服务
主要功能就是由客户端请求启动,停止ECU中的例程或请求例程结果 简单介绍一下例程,就是一段写好的代码,可通过例程控制服务,去执行这段代码。... 爱知ev
- 0
- 8
- 5.7k
-
车载以太网DoIP协议(下)
上文中我们介绍了DoIP的报文格式和简单的交互机制。今天我们来进一步看看如何利用DoIP进行车辆诊断,以及ISO 13400定义的诊断会话中的细节要求。... 秋名山车神
- 1
- 2
- 1.8k
-
UDS统一诊断服务【二】ECU复位0X11服务
ECU复位服务,其服务ID是0x11,主要功能是控制ECU执行复位动作,主要用于Client向Server(ECU)请求重启行为,该重启行为将会导致Server复位回归到特定的初始状态。... 爱知ev
- 1
- 3
- 820
-
SOME/IP 详解(3) —— 通信方式
前面的文章给大家介绍了SOME/IP的功能、标准和报文格式,接下来我们开始介绍更多和实际应用相关的内容。首先,是通信方式。看看SOME/IP是如何通信的,节点之间是如何通过SOME/IP进行交互的。... 秋名山车神
- 0
- 1
- 554
-
UDS统一诊断服务【四】通信控制0X28服务
通讯控制服务主要用于开启/关闭电控单元对某些报文的发送或接收,例如,当通过UDS协议下载程序时,可使用此服务停止其他非诊断报文停发,从而将带宽都用来下载,这样就可以加快下载速度。... 爱知ev
- 0
- 2
- 1.4k
-
SOME/IP 详解(4) —— 数据类型
SOME/IP数据类型是该协议中的基础概念,了解数据类型可以帮助我们理解SOME/IP的工作原理和实现方式。在做通信设计时,需要根据具体的应用需求和复杂性,选择合适的数据类型。简单的说,数据类型就是SOME/IP报文的Payload中要传输的数据是什么样的结构,以及如何排列。... 秋名山车神
- 0
- 1
- 579
-
-




















































